MONTH ON X AXIS NOT IN CALENDER ORDER

The month on the X axis is not in calender order.

Best Answer

  • ROXANNEB
    Accepted Answer

    That doesn't seem to work.  I have tried filtering it by the month, and does not make a difference.  Is there a setting that would allow us to change this order, or a formula in beast mode that may work?

     

     

Answers

  • make sure the date field your using is loaded as a date or datetime data type. Also, i would sort the chart by the date field to make sure it stays in order. 

  • Sounds like the date value you are uising is not a Date data type. You have couple of options:


    1. You may want to consider fixing that through your data load process.
    2. Create a Beast Mode calc using a CASE function to map Jan-Dec text values to a numeric sortable value, and drop that into the Sort criteria.
    3. Try converting your data column using the following beast mode and see if that will fix the issue. 

      STR_TO_DATE('DateCol','%m,%d,%Y')

This discussion has been closed.