amount field type importing as Text

ANyone know why when i select a data source with an Amount Column, Domo is recognizing it as Text rather than Amounts?  How can i correc this?

Comments

  • where does the data originates from before making it into Domo ?

    from a sql view uploading through wrokbench ?

    from an excel spreadsheet store in your machine or in box or other uploading it into Domo using a connector ? etc

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • an excel file on a server

  • if you can , go into the excel and make sure that all values in the columns showing amounts has nothing other than numeric values... what happends is that usually the excel is updated by a person and if someone enters a text value by error in one cell , it makes the whole column a text column. 

    it could be a comma , a space or anyother value what is turning the whole column into text.

    make the correction, save and re-run the load into Domo.

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • I don't see anything other than values in the column

  • Can you run a formula on your excel for that column ... =ISNUMBER(yourcolumncell)   and drag it down til the last record, see if any returns false

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • I did that and there are no False

  • Gosh ? i'm running out of ideas.

     

    is the column generated from a formula in the excel ?

     

    last thing to do is to create a data flow in Domo , magic etl , bring the input dataset and from the edit column menu use the set column type option to force the column to display as number instead of text in Domo.

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • No, just contains numbers

  • @sgraham, were you able to resolve your issue?

  • You can put it through a dataflow and cast to number.

This discussion has been closed.