CSV Workbench job, replacing dataset: "Given key was not present in the dictionary"

I have a Workbench job that's parsing a CSV and had been working fine for some time, but we ran into an issue with the source system and we want to load a new CSV with a year's worth of data, replacing the current dataset. File format is identical. When I try running the job with the new csv file, I'm getting the error "The given key was not present in the dictionary."

 

Should I take this to mean that there's an apparent field mismatch between the dataset and the Workbench job?

 

Thank much!

 

==

Chris

Comments

  • AdamT
    AdamT

    domo

    💎

    Hi @northshorehiker - Which version of Workbench are you using? 

    -----
    I work for Domo.
    **Say "Thanks" by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as "Accepted Solution"
  • Thanks for the response, Adam... looks like version 3.1.5714.35059

  • AdamT
    AdamT

    domo

    💎

    @northshorehiker Are you able to see the "column mapping/filtering" panel for this CSV job? I am thinking the same as you, that one of the column names have changed or the date type is not mapped correctly.

     

    From the Knowledge Base: http://knowledge.domo.com?cid=wb3userinterface

     

    "Column mapping/filtering panel

    For any DataSet, you can access a panel that allows you to configure options for all of the columns in the DataSet. For any given column, you can change the names of the source and/or destination columns, include or exclude certain columns in the DataSet, encrypt the data in certain columns, etc. For Excel and CSV files, this panel appears automatically when you select a file. For other DataSet types, you must click the Column Mapping link. "

     

    I would go through the mapping for your columns to make sure everything is appearing as expected there.

    -----
    I work for Domo.
    **Say "Thanks" by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as "Accepted Solution"
  • @northshorehiker, did @AdamT's response help you?

This discussion has been closed.