DOMO importing columns from Google Sheets that don't exist.

I'm importing some data from google sheets. I occasionally edit the columns in the sheet. When I re-import the data in DOMO, it keeps importing the now deleted columns. The deleted columns also continue to show as a selection when making a card. 

 

Any Idea how to fix this? The only success I've had was to delete the data source and re-import it as if it were brand new. 

Best Answer

  • PodiumMason
    Accepted Answer

    @Sweep_The_Leg You know what, I just looked at the connector and it doesn't look like it actually has the functionality to switch between append and replace. Interesting.

     

    Have you tried creating a brand new dataset and importing the sheet, do the old columns still pull over? This could be a legitimate connector bug that should be reported. It's also concerning that changing the schema doesn't carry through to the final output dataset. Both of these things should probably be reported through Domo Support. 

     

    Let me know if you have any additional questions. 

Answers

  • Hey mbauer,

     

    Do you by chance have the dataset set to append, rather than replace? The only thing I can think of is that the connector is attempting to append a new schema to the old one, so you get the old columns as well. 

     

    If that's not the case, I would recommend reporting a bug to Domo Support.

     

    Let me know if the above is helpful!

  • Sorry for the late reply. Unfortunately I don't see the settings for either Append or Replace. 

  • Yes, it seems the only way to correct is disconnect entirely and re-import as if it were brand new. But I'll take your suggestion and report it to the support team. 

     

    Thanks again!