Fullpage Domo Card

I'm developing a new card and can't figure out how to get the fullpage setting in my manifest.json file to work.  I have fullpage: true specified, but the sizes are still being used to make the iframe container in Domo a specific width and height.

I've tried everything I can think of.  I've excluded sizes with fullpage, which uses 1x1 (expected behavior).  I've tried specifying fullpage in different places in the manifest object, which shouldn't (and doesn't) make a difference.  Has anyone actually gotten this to work?  Here's my (slightly redacted) manifest:

 {
  "name": "App Name",
  "fullpage": true,
  "version": "1.0.0",
  "size": {
    "width": 4,
    "height": 6
  },
  "mapping": [
    {
      "dataSetId": "********-****-****-****-************",
      "alias": "myalias",
      "fields": [
        {
          "alias": "myfieldalias",
          "columnName": "Column Name"
        }
      ]
    }
  ],
  "id": "********-****-****-****-************"
}

I also attached a screen shot of the container getting applied a 930x1700 height.  That maps to my sizes of 4x6 (930x1700 according to the documentation)

Thanks in advance!

Best Answer

  • Robert
    Answer ✓

    Scratch that.  I found a checkbox at the top of the card edit screen that enabled fullpage.

Answers

  • Any chance you could post a screenshot?

  • I encounter the same issue. Checking the 'Fullpage' checkbox in edit card screen only fixes the issue temporarily. If you re-publish your app, your card will go back to 'non fullpage'. I wonder if there is a way to make 'Fullpage' persistent without the need to re-edit your card after publishing?

This discussion has been closed.