Heatmap Table Colors Not Working

I am trying to use the HeatMap Table (please note that I am not trying to use the 'Heat Map', but rather the 'Heatmap Table' under tables), but unfortunately I am not having any luck getting the colors to reflect the variances between the numbers. Any assistance on this would be great! Thanks.

 

Attached is an image of the table I'm trying to modify.

 

Best Answer

  • RGranada
    RGranada 🟢
    Accepted Answer

    I Think i know what is going on.  Domo is using the year number to calculate the intervals of your heat map.

    One way to avoid this is no to allow Domo to do this by making impossible for Domo to convert the year to a number.

     

    You can achieve this by using the following beastmode instead of the year field:

    Concat(' ',`Year`)

     

    Sending a screen cap illustrating my idea.

    Hope it helps!

Answers

  • AS
    AS 🔵

    I bet your null values are involved in the distribution monotony.  I'm not sure how to handle that.  That said, I like to change the scale to log as well as change the theme to one that has more colors.  Try a combination of those and let us know if it helps.

  • Thanks AS for your response! I tried replacing the null values with zeros, but unfortunately it still did not fix the color scaling. Attached is a copy of the new table with zeros.

  • Are those all the values you wan't to show?

    What is your minimum value and maximum Value?

     

     

  • Yes, those are all of the values I am wanting to show. The minimum is 0 and the maximum is 291.

  • And there are no nulls, right?

    Are there any aggregations on the columns?

    Are the chart properties the default ones?

     

     

  • This is an aggregate of the columns and the chart properties are set to default.

  • Also there is  a kind of a bug here, because even if domo takes the values in the first column into account while calculating the max and min values, it does not apply the interval color to the first column.

     

    You can verify this with a simple swap of the columns.

     

    Hope this helps!

  • Thanks RGranada! That solved it for me!

This discussion has been closed.