Always has timeout when trying to connect to my Mongo database server

Hi,

I haven't had any successes connecting to my Mongo database and always have this issue

Pasted image at 2017_08_10 01_13 PM.png

 

I'm sure I put right Credentials. However, I can't know if my Credentials work or not because I tested with both right and wrong Credentials and the connector always confirm it is connected, and I can't have a list of collections but only manually type it by myself. Then when I run the dataset, the timeout problem always appears.

Can anyone help me with this ?

Thank you.

Comments

  • Hi guys,

     

    I'm working on connecting MongoDB into Domo using the inbuilt connector & have been unable to do so.

     

    Having tried various combinations and configurations of Collection, JSON queries - it's just not working, leeps failing and below are the details

     

    The only error message is as follows

    ERROR: Time out.

     

    Trials: - this is what I have tested and tried in Domo connector

    Collection : users ;  database.users    etc 

    JSON Query: {subscriptionType: 'free'} ;  db.user.find( {} ) ; {}   etc

     

    All of these work in MongoChef (Studio 3T) but not in the Domo connector, which is weird!

     

    Is there any example of Collection and JSON query that is available where we can understand how to make this connection and load any data for testing initially? Or atleast some guidance on what the errors are?

     

    Would highly appreciate your feedback and any direction on solving this

  • Hi All,

     

    I've been using Domo for the past few months pulling data from a MongoDB. 

     

    It has been working fine but 18 hours ago the data stopped flowing. Looking at Domo it shows Timed Out. I have tested that I can connect from my machine and others to the Mongo Database. I've also checked the server and it all seems fine.

     

    Any idea what i can do to t-shoot?

     

    Thanks

  • Anyone have ideas? We can no longer get our data in. I've checked everything on the db and it looks fine.

  • Would anyone be able to help out with this?

  • Hey,

    I'm facing the same issue. Did you find any solution ?

  • DaniBoy
    DaniBoy

    domo

    💎

    @Millhouse

     

    Can you look in to this please?

     

    Thanks!

  • Did this get resolved yet? 

     

    Facing same issue! 

  •  @DaniBoy  

    Looks like this is a reported issue!

     

    Kindly help us out by checking and testing this. A clear example is needed and data should be flowing here for it to work

  • Greetings,

     

    I have consolidated the various posts in one location.

     

    @Millhouse can you provide any upudates on the MongoDB issues?

     

    Thanks!

  • Hi all,

     

    In response to some timeout issues that we had been seeing with the Mongo DB Connector, we upgraded the driver version of the connector and that resolved some of the issues. If you are still seeing timeout issues with the Mongo DB Connector, I would encourage you to open a ticket with Domo Support, and then we can take a closer look at what is going on.

     

    Thanks!

  • Same issue here.

  • I merged the two conversations, please see the update from @Millhouse.

     

    In response to some timeout issues that we had been seeing with the Mongo DB Connector, we upgraded the driver version of the connector and that resolved some of the issues. If you are still seeing timeout issues with the Mongo DB Connector, I would encourage you to open a ticket with Domo Support, and then we can take a closer look at what is going on.