Workbench Error : ODBC cannot open the Access Database

Hello,

 

Attempting to upload the MS access database on the workbench will result in the following error message.

 

 

ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver] (The file name&path) The database cannot be opened in exclusive mode because it contains links in cached mode. 

 

Previously, the predecessor could upload it, but now she also has the same error and can not upload.

 

I can open the database in exclusive mode .
But My workbench cannot open it.

 

(By the way, it is possible for other jobs to open other DBs and upload them at my workbench.)

 

If you know the solution, please let me know.

 

Regards,

Hara

Comments

  • Hi,

     

    Did the security settings on the folder where the db is located change?

    Make sure users workbench or impersonated user have read, write, and create rights for the folder in which the database is located.

     

    Hope this helps.

  • Thank you for your advice.

     

    The security settings of the folder was not changed.

     

    But after asking a question, I was the one what came up with it,
    The query I wanted to upload was created with link tables from other DB.
    So, I created the same query in the DB, and created a job of Workbench and uploaded it, it worked just fine.

     

    For the time being I can operate it!
    Thank you for your cooporation.

     

    Even so,I am in doubt that workbench can't upload queries made from link tables from other DBs.
    My predecessor says that it was able to do before.

    I feel that the link table is not the real cause.


    Please let me know.

     

    Regards,

  • Hi,

     

    Do you have the odbc access configuration set to open the db in exclusive mode? If so do you really need that?

     

    You can configure this in the odbc driver under options: 

     

     

    DOJO_Access_Exclusive_Mode.png

     

    Hope this helps.

  • Thank you for your response.

    I don't set odbc access configuration to open the db in exclusive mode.

     

    But,Workbench tries to open the DB in exclusive mode.
    Then,it occurred error.

     

    To open link table, Does workbench need to open DBs in exclusive mode?

     

    Regards,

    Hara

This discussion has been closed.