Page Filtering across datasets

I have a page with multiple cards built on multiple datasets, but all of the datasets have a common set of columns that contain ways to filter the datasets (I will call these "sorting columns"). The sorting columns were joined to the datasets through Magic ETL and/or Redshift. When I add page filters and choose a dataset and filter based on one of the sorting columns it only filters the cards with datasets that had the sorting columns joined in the same manner, either Magic ETL or Redshift. Has anyone else run into this issue, if so what can I do besides joining all of the sorting columns to the datasets in the same way?

Comments

  • You need to check the box at the bottom of the page filter:1.png

     

     

     

    As long as your sorting columns have the same field name, it should apply to all of the cards.

  • I have that box checked already and the field names match exactly, but still having that issue.

  • I'm experiencing the same issue. Were you able to find a resolution?

  • I am still able to set up a page filter across multiple data sets on a page.  I would suggest that if these steps are not working for you, that you open a ticket with Domo.  The first step is to ensure that the field name and the data type are the same for all of the data sets you are using on the page.  After that, open the page filters and select a dataset and field name that you want to filter for.  You need to make sure that you also click on the "Apply to all DataSets with `FieldName`" option.  Click on apply, then save filters to page.  You should then see a blue icon in the top left of any cards that are receiving that filter.Choose the fields that you want to filter.  Make sure to apply to all datasetsChoose the fields that you want to filter. Make sure to apply to all datasets

     

    Make sure you save the filters to the pageMake sure you save the filters to the page

     

    Look for the blue icon at the top of your cardsLook for the blue icon at the top of your cards

     

  • Has this feature been removed? I don't see it now and it's asking me to choose a single dataset to filter on.

This discussion has been closed.