XML Importing 1 Row

When I use the Domowork bench to push an xml file to a data set, it will import every attribute as a new column thus making it 800ish columns x 1 Row and incrementing the column name by 1. Is there any fix for this ? I dont have this issue when manually importing it using XML easy but I need the schedueling feature that workbench creates. 

 

thanks

 

 

Best Answer

  • AS
    AS 🔵
    Accepted Answer

    It took me a bit to get my XML jobs coming in correctly. 

     

    It might be the Flattening Options setting, found on the Source menu.  I have mine set to 'Deep' instead of 'None' or 'Wide'

     

    Does that help?

Answers

  • Hi Aaron,

     

    Do you have a screen shot of those settings?  I am not able to find it in the source menu in Workbench.

     

    Thanks,

     

    Jay

  • Hi Aaron,

    I only see those options for JSON, not for XML.  Am Imissing something?

  • AS
    AS 🔵

    My file is actally JSON, the job is set to XML type, and the settings are as attached