Page Filter Randomly Disappearing

Our company relies heavily on page filters being present for our users to filter pages as needed. 

These page filters are applied and remain on the pages for periods of time but randomly they will just disappear and need to be resaved to the page. The requency of these filters disappearing is about once a month.

I am the admin of the pages and am not removing these filters and the data sets on these pages are not changing.

 

Is there something that could be causing this to happen?

 

Thank you 

JP

Best Answer

  • frwern01
    frwern01 🟠
    Accepted Answer

    We've run into the same issue. Domo explained to me that the Page Filters can be added/removed by anyone else in your organization that has access to the page. Even when the page is locked. The values entered into the Page Filters are unique to the user but the filters themselves are shared by everyone. I've had to send multiple emails to all users several times to get people to stop removing Page Filters they feel they do not need. I provided Domo with our use case scenario at Domopalooza but no security updates have been annouced to fix this issue. Sort of like the Shared Beast Mode calculations. We removed all Shared Beast Modes from our cards as any individual can decide to change the calculation on their card but it changes the calculation on every card. No security lock out available.

Answers

  • Hi,

    Is anyone able to help out with this request?


    Thanks,

  • Hi @user008814,

     

    We are having a similar issue with page filters, although at a higher frequency than 1x per month. Were you able to resolve the issue?

     

    Thanks,

    Danny

  • We found that the issue that causes this is that even though the values that you entere into your filters and save to page are user specific, the filter items that appear on the page are shared between users. If oine user, deletes a filter, it disappears for all other users. This is a severe problem for us as well. The same thing happenss if the filter is set to be apllied to multiple datasets and someone uncheck the box to apply he filter to "all datasets" - it disappears for everyone. Filters should be totally user specific. We would rather train someone to set up their filters rather than have them frustrated due to them changing and disappearing.

  • Hi, I was having that problem but after moving people who didn't need admin access to another level, it stopped.  What I do have a continuing problem with is the filters being turned off randomly.  I have to keep directing users to go to the wrench and turn the page filters back on.  Even after they have been turned back on, they end up being turned off which is getting confusing to users.  Is there a way to centrally make sure all page filters are turned on?  

This discussion has been closed.