Failed to authenticate. Verify the credentials and try again. Error setting up SQL connection. FATAL

Hi, 

 

We have a Postgres database running on an EC2 server on AWS. We have whitelisted the IPs and set up an account to use SSL:

 

our pg_hba.conf includes:

 

hostssl all readonly_user 0.0.0.0/0 md5 clientcert=1

 

We are using a self-signed certificate, mostly followed the directions here:

 

https://www.howtoforge.com/postgresql-ssl-certificates

 

We are receiving the following error in Domo when attempting to connect:

 

Failed to authenticate. Verify the credentials and try again. Error setting up SQL connection. FATAL: connection requires a valid client certificate

 

Any suggestions? 

 

Comments

  • Hello!

     

    A few thoughts:

    • Make sure you are using the "PostgreSQL SSH" connector, not the normal "PostgreSQL" connector.
    • In whitelisting IP Addresses, see this document: https://knowledge.domo.com?cid=connectorips 
      • NOTE that there is one extra IP that should be whitelisted when using SSH connectors, make sure you have not missed that one.
      • NOTE that these IPs are to be whitelisted in your EC2 environment and in your PostgreSQL database, not in the Domo Admin settings (Whitelisting in Domo Admin Settings is a different function altogether).
    • Finally, working with a DBA of your PostgreSQL server (if that's not yourself), and with an administrator of your EC2 instance, review each of the settings listed in the PostgreSQL SSH connector configuration area for accuracy.
      • The primary focus here, based on your error message, is to make sure that you have the correct Private Key listed in the Private Key field. If you have a certificate, but not a private key, contact Domo Support. They can help you extract the key from the certificate, or any DBA/Network Administrator is likely to know how to help with that as well.

    Let us know if this information was helpful.

     

    Thanks!

    Starlord

    Starlord
    **Say “Thanks” by clicking the “heart” in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • Hi user08502,

     

    There are 13 IP addresses that need to be whitelisted to your Database and your network AND SSL has to be enabled. This allows Domo to access the data inside of your database and not inside Domo. Please make sure that you have entered all the IP addresses in correctly. You can refer to this Knowledge base article which has all the IP addresses on it.

     

    https://knowledge.domo.com/?cid=connectorips

     

    It also looks like your Database is requiring a certificate in order to authenticate. You will need to get that certificate and enter that into the configuration of the connector.

     

    "CA certificate text or URL path is required only if you select Certificate text or URL path, respectively, in the Certificate type menu."

     

    https://knowledge.domo.com/?cid=postgresql

     

    Hope this helps!

     

    -Jarvis

     

     

This discussion has been closed.