Workbench 3 Messes up Dates in Preview

I was wondering if anyone else has noticed how Workbench subtracts 5 hours (at least for Central Time) from the dates in Preview so they are in UTC time even when the job is set to Central time. This causes issues with the Append to Data source because the date used to compare to the date variable is in UTC time while the variable is in the user's time zone. Why would Workbench Preview CHANGE the data I'm uploading in the first place?

 

Once it gets into Domo, the dates are correct. This still has caused a lot of frustration for me when trying to make sure the correct dates are used with my cards.

 

This is the data straight from SQL Server.

Original Dates from SQL Server

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

These are the dates that show up when I set the job to use Central Time.

Workbench Dates Central Time

 

These are the dates when Worbench job is set to UTC.

Workbench Dates UTC

 

This is the data in Domo using a Sumo Table after uploading from Workbench set to Central Time.

DomoRawDataCentralTime.PNG

 

This is the data in Domo using a Sumo Table after uploading from Workbench set to UTC. (Not in the same order as the screenshot above but you can match up the percentage fields.)

DomoRawDataUTC.PNG

Comments

  • This is very interesting, and it sounds like a worthwhile question for one of the Domo developers.

  • Let me try to explain what is intended to happen here.

     

    First, Domo expects all datetime data in its tables to be in UTC time. Everything is kind of based on that assumption. To adjust how data is treated in the Domo web UI, you can go into the Admin section under Company Settings. On the Company Overview page there is a timezone setting. Setting this will make the product adjust your displays to show data in your company's timezone.

     

    Second, due to the first assumption, you will want your Workbench jobs to adjust the data during the import process to be in UTC. So in the Job Settings page, you set in which timezone your data in SQL Server actually is, and then Workbench will adjust it to UTC during the upload (and preview).

     

    Hopefully that helps.

  • @joecrabtree, did jeremyhurren's reply help address your issue?

  • That reply really doesn't help. When the timezone is set to UTC in Job Settings, Workbench adds 5 hours to my original datetime values IN THE PREVIEW. This screws up the Append to Existing Data Source option because now Workbench thinks the last datetime in the data is five hours later than what was uploaded previously. 

     

    I have the website set to Central time already so again this shouldn't be an issue.

     

    My biggest concern is why does Domo Workbench change the original datetime values in my dataset? If I want the date to be 2015-7-20 12:38, Workbench should take that datetime and upload it directly to the Domo date warehouse without any manipulation. 

     

    See my screenshots for more information.

  • Hi all,


    Does anybody have any further insight into @joecrabtree's question?

  • Austin
    Austin

    domo

    💎

    @joecrabtree,
    If you have your domo instance timezone set to Central Time then you will want to ensure that your Workbench job settings are set to UTC that way the data will automatically convert once it has been uploaded. If both the domo instance and the workbench job settings are set to Central Time then it will essentially double convert and not represent the data correctly. This is something that you will want to prepare for in the append query and take the 5 hour difference into consideration, but we would be more than happy to submit an enhancement request so we can take a look into providing a feature that doesn't require this down the line.
    -Austn
    Domo Support

This discussion has been closed.