Hide a column data fusion

Hi,

 

Currently handling tremendous set of data in the data fusion, I would like to hide some useless columns. I went to the edit DataFusion where the joins are made and below it should be the place where we are able to hide the rows. However the display won't show. I wonder if it was because of the amount of data that I have : about 300million of rows and something close to 200-300 columns.

 

Is there any other solution to hide columns from a data fusion?

 

Thanks a lot

Best Answer

  • creed
    creed

    domo

    💎

    Accepted Answer

    Hi @user07367

     

    You should be able to rename and/or ignore unecessary columns in the Fusion editor. Simply click on the arrow next to the column name and select "Ignore Column"

     

    Screen Shot 2018-12-11 at 12.44.51 PM.png

    Here's a link with more information: http://knowledge.domo.com?cid=usingdatafusion

     

    Thank you for the screenshot. I suspect that the error is related to the size of the data preventing the preview. Have you tried ignoring the column and then saving the Fusion to see if the change goes through?

     

    Thank you,

    Creed

     

Answers

  • Nek
    Nek ⚪️

    Hello, 

     

    I always hit the same error on DataFusion, exactly the image attached by another user (user07367). 

    For sure I am still able to save it and go with the blended data, however, the error comes whenever I update, add / replace / remove dataset in the datafustion edit. Without the preview loaded, it is not able to remove extra columns in such case and create a very wide and huge dataset. I think it doesn't make sense to create a new datafusion to facilitate this, especially when we have already created multiple cards with the datafusion dataset. Hope Domo team can provide a solution to this. Thank you!

     

    stay healthy, everyone!

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤

    @Nek  here's a tutorial video on how to alter your Fusion using the Java CLI.

     https://www.youtube.com/watch?v=9HYx1vn3HRM

     

    In your case you'd want to drop columns under the MAPPING and the COLUMNS clause

  • Nek
    Nek ⚪️

    Thanks a lot Jae! However, I don't see 'Security' in my Domo Admin page and not able to get a access token, it should be due to corporate settings, though I am able to download the CLI - will still try it out later anyway. I've also watched your other youtubes before, those are great and super helpful, thanks for your sharing!!

     

    (my current solution is to create extra ETL or SQL to get and rename the data fields required, then blend to the datafusion)

     

    stay healthy!

    Nek

     

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤

    Ask your Domo Admin to generate an access token for you.