0 record dataset update

Question: When a scheduled run of a dataset returns records, the dataset is updated.  However, in subsequent runs when the resulting record count is 0, the dataset is not updated and the Last Run time stays as previous.  How do I force Domo to make the dataset have 0 records which is the result of the last run and also update the Last Run time and not ignore the fact that it couldn’t find any records.  This dataset is used for an AR Aging report with the goal of 0 records in the dataset. 

Comments

  • How are you loading that data to Domo? Does the dataset not update the first time it gets to zero, or the first time it goes from zero to zero?

    Domo workbench has a configuration setting to "upload even if data hasn't changed."

    Also, there's another setting to be aware of.  From the knowledge base:

    Clear Domo DataSet if DataSet Job returns zero rows 

    Lets you clear the DataSet in Domo if zero rows are returned when a job runs. If disabled, Workbench does notsend a command to Domo to clear out data in the DataSet. If you have a process where you want to upload data in a table after data in another table has been updated, you could disable this option and add some script in your query that looks at the "status" table, running the query if the data is ready.

  • The dataset is connected to an Azure account DB (not workbench).  Is that option available (clear dataset if zero rows)?

  • I'm not familiar with that connector. Perhaps another community member or Domo support has an answer to that.