Beast Mode update

It seems like in the new Beast Mode you can't look through a list of previously written calculations on the data source. When you open Beast Mode via the 'add a calculated field' button you can only see a blank template for what you want to work on. 

 

It also seems like a Beast Mode calculation isn't available outside of the card upon which it is created. I wrote a beast mode on a new card, saved and started working on a second card on the same data source. The calculation I had written did not appear in the values or categories lists in builder.

 

Domo folks, any advice here, or any insight into updates coming? I'm having to open multiple tabs, find the cards where I wrote successful beast modes, and duplicate them on subsequent cards that need the same calculation applied. While I'm loving the new builder and beast mode writing functionality, this is a major setback to the process of working with beast mode calcs.

 

Thanks for any insight you can share!

Tagged:

Best Answer

  • jmo
    jmo
    Accepted Answer

    It sounds like you may not have saved those Beast Modes to the datasource. You can see that check box underneath the function description window below.

    Beast Mode Window

     

    Also, as @Anthony_G mentioned, there is no longer a list of Beast Modes in the editor. You can look them up in the list of fields. All Beast Mode calcs have an equal sign next to them (see "MOM SPLIT" in the image below). You can click on them to open up the editor if you need to make changes. Note the search filter above the list of fields.

     

    Fields

Answers

  • You have to double click a beast mode in the list to see its code now. Beast modes are labeled with an equal sign in front of their text.

  • Thanks, I did see that. However, I'm still concerned that the previously written beast modes don't show up in the values/category lists when creating another card on the same data source. I am used to beast mode calculations being available across my instance, as long as I am working with the data source upon which it was created and saved.

  • Oops, I didn't see the checkbox! Phew, so glad that's still in play. I appreciate that and the rest of the very helpful tips.

     

    Thanks to both of you @jmo and @Anthony_G!

     

     

  • It works . Thank you Smiley Happy