Excel from SFTP workbench error

Trying to upload an excel file with multiple sheets using Workbench from an SFTP server, When I validate the settings I get the error: Path extension '.tmp' is not supported. Use ExcelFile.Load method that accepts LoadOptions paramter to explicitly specify source file format. Parameter name: path


The path is in the following format, specifying the file type that is to be imported.



If i change the name of the file i'm searching for to an incorrect value it says the file does not exist, so I know it is resolving the path.


If i run the job anyways, the data comes across but only from the first sheet in the dataset. I cannot specify a sheet to pull from.


any ideas?



  • That looks like a bug in validation to me.  You should be able to pick the sheet.  What happens if you preview first?

  • When I run the preview it loads the first sheet of data from the workbook correctly, but also gives me the error "Workbench DataSet Job xxxxxxx.domo.com:13 (XXXXXXXXX) is not allowed to dynamically change schemas."

    After previewing I can still not select a sheet name form workbench.

  • That schema change error is a configuration option you can check/uncheck on the settings for the job, toward the bottom of the page under the heading Additional Settings.  Make sure you've checked that the job can "allow schema changes" (at least for now).


    What happens when you preview, without error, and click on the Sheet Name dropdown under the Data Source Properties section of the Source tab?  Does it now show all the sheets, or when you click on that dropdown does the interface not do anything?


  • allowing the schema to change fixed the preview error I was getting, but I still cannot select a sheet even after the preview has run without errors.

  • Partial victory?

    What does the interface do when you click on the dropdown?  Does it expand but only show the one sheet?

  • I suppose, never impacted the run for the first sheet data though.


    The interface still doesn't do anything when clicking on the dropdown, doesn't even show the first sheet


    Thanks for the help, I'll have to see if i can find a workaround for this.

  • Sounds like a bug.  It works for me.  Consider contacting Support.

  • I know this is sort of an older case but want to put in that I ran into this error today (using wb 4) and ended up just re-creating the job and it cleared up.  I think I had saved/edited so much something just got screwy on the back end.

This discussion has been closed.