Whoops! Something went wrong.

I have a dataflow with 50+ transforms that has been working.  Recently I added some more transforms to it and now when I run the final transform that joins all the other transforms together I get this error in red "Invalid" next to the RUN SQL button.  Usualy if there is a syntax error or a missing transform it will tell you what the issue is and on what line.  I don't get a helpful error message. It just reads  "Whoops! Something went wrong." 


If I just run again "RUN SQL" some times it will finish with a green Valid message.  If I don't change anything and hit "RUN SQL" again it will fail with "Invalid" and "Whoops! Something went wrong.".  I can keep hitting RUN SQL over and over and its like flipping a coin on Invalid or Valid.   I tried commenting out the joins to the new transforms and this doesn't seem to make a difference.  It does seem to run valid more but it will still fail Invalid.  Time of day does seem to have an effect on this.  In the afternoon it will return Invalid more often than Valid.


Dataflow specs:

Data Input 1.7M rows / 1.39 GB 

Data Output is 436 rows / 1.26 MB


Is there a transform timeout limit that I'm running into? 

If so can this timeout limit be increased per dataflow or for my entire instance? 

Maybe my Domo instance needs to be migrated to a bigger AWS server with more processing power and faster disks?



  • "Whoops! Something went wrong." is often a system issue, I find.  It could be a hiccup in network or something on the Domo side.  Although, the fact that it also flips to "Invalid" is curious.  


    This is a bit like asking if you've restarted your computer and cleared cache...but...

    Have you gone through your transforms in order from top to bottom, running the SQL, and then hitting save and run at the end?  I have found that this sometimes helps to smooth out the SQL function.  If that works, just make sure to do that whenever you make changes to the query.  


    If this doesn't work, perhaps some screenshots can help us figure it out.  

  • I just figured out a solution to this issue.  Not too long ago some new features rolled out and one of them is a tab on a transform that reads "Indexing".  I went through my dataflow and put an index covering each column for each transform that is joined on in my final transform.  Now I no longer get the "Whoops! Something went wrong." message.  This also took the run time of my dataflow from over an hour down to 5 min.



  • That is fantastic!!! Great work @DBandrew!!!
  • I can't seem to get anything besides invalid and whoops something went wrong, is there any way you could guide me? Lol I'm new to all of this. I've included a screenshot!