Hover Text Settings: %_of_Category not working correctly

I have a card where it is the last 14 months, graphed by month, and the X axis is the date.    The Y Axis is the count of deferral codes, and the series is deferral code descriptions.

 

For the Data Label Settings, I have entered %_of_category, and it works just fine.   The problem was that some of the series are so small that the data label doesn't show for them.

 

So, I added Hover Text as well, the same %_of_category, and noticed that this also lets me hover over the legend to get the %'s of the very small series.   But for some reason, the percentages that are showing for hover text are not at all accurate.   Instead of giving me the percent of the category, it is just taking the total for each month (count of deferral codes) and adding a % sign.   So for example, September had a total of 7005 deferral codes, and the hover text just says 7005%.   I don't understand why it works correctly for data label setting, but I'm having this problem with hover text settings.

 

Am I understanding "%_of_catgeory" correctly, where in this case the category would be each month since that is the X axis and it is graphed by month?   I would think I am because the data label gave me the correct numbers I was seeking.

Comments

  • AS
    AS 🔵

    Can you copy the exact macro text out of the data label and hover text settings?

    "%_of_category" isn't an actual macro, so you would actually see that exact string come out on the chart.  However, "%_PERCENT_OF_CATEGORY" is a valid macro.  See the difference below:

     

    macro.JPGmacro2.JPG

  • I took another look to make sure I had a valid macro in use for my hover text setting.  While doing thing, I think I figured out what I had wrong.   Under "hover text settings," I had "Hover Format" set to "Percentage."  I was thinking that hovering over the series in the legend would work the same as hovering over the graph with percent of category, but I think hovering over the legend just shows the count value of the graph.  So having the hover format set to percentage was just adding a percent sign to the count when I would hover over the legend.   

This discussion has been closed.