connecting to oracle Database from workbench 5

Hi,

 

I'm new to Domo administration, I'm trying to connect to Oracle database(12c) to create Dataset in workbech 5 version and i'm facing an issue when trying to connect to oracle database.

 

1. In workbech under  "ODBC Connection Provider Editor" I have selected driver "Microsoft ODBC for Oracle (32-bit)" to connect to Oracle DB and I encountered with following error.

"ERROR [IM004] [Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_ENV failed"

 

2. could you please point me in right direction to resolve the issue to connect to Oracle Db to create dataset in Workbech.

 

Thanks,

Hari

 

Comments

  • I found this on another user board:

    https://forum.uipath.com/t/error-im004-microsoft-odbc-driver-manager-drivers-sqlallochandle-on-sql-handle-env-failed/79288/3

     

    Had the same error when hosting .asp website that was making a connection to an Oracle database using the ODBC driver on Windows 2016 server. Found the below steps on a site. Couldn’t paste the link so I copied the steps.

    This can occur if you have an invalid or incorrect PATH variable. To check your PATH variable:

    1. Right-click My Computer
    2. Choose PROPERTIES | ADVANCED | ENVIRONMENT VARIABLES
    3. Locate the PATH variable and copy it"s contents to a text editor such as notepad

    Once you have done this you should now look for the following:

    1. A missing semicolon between the different application paths. Each application path in the list should be separated by a semicolon.
    2. Look for spaces between the semicolon and the next application path. Remove any spaces.
    3. If you have more than one Oracle installation, make sure the latest version appears in the PATH before any older versions. If you have uninstalled older versions and references still exist in the PATH then remove them.

    If the PATH appears fine then the issue may be rights related.

    1. Opened up Windows Explorer
    2. Navigated to Oracle | ora92
    3. Right clicked and selected properties
    4. Clicked on Securities tab
    5. Clicked on Authenticated Users
    6. Unchecked Read and Execute | Click Apply
    7. Rechecked Read and Execute | Click Apply
    8. Clicked ok to close window
    9. Restart server

     


    Hope that helps