Workbench 5 TXT File upload

Trying to upload a TXT file to Domo that is 301,321 KB and 1.7M rows, anyone have any tips? I can't seem to make any connectors work. They all give me the same error that a file cannot be larger than 254MB. Also, has anyone tried to use the Access app? IT asks for SFTP Hostname for a Microsoft Access connector and the port number?

Best Answer

  • Unknown
    Accepted Answer

    A couple of things to try:

    - TXT files compress really well (assuming you mean a CSV file) . If you put it in a zip file, you can use an email connector or a dropbox connector to send in the zip file, which Domo then auto-extracts the CSV file from

    - There's also the 'legacy' file upload connector, that uses a different method/library to do the upload (the one that shows an upload progress bar) and potentially doesn't have that issue. You'll find it here (insert your domo domain name): https://{your_domo_domain}.domo.com/appstore/connectors/com.domo.connector.fileupload.legacy?origin=dc&classification=UPLOAD

    - Finally, our company developed a python script to stream files up into Domo using the 'straming API' but it's a lot more complicated to use. You'll find the open-source code here: https://github.com/BlueBikeSolutions/domo-stream-uploader

     

    Good luck (I reckon the zipped file is the easiest approach)

     

    P.S - Workbench definitely shouldn't have those constraints...not sure why you'd hit limits with that approach

     

Answers

  • I am exporting a large table from Access TXT, then I saved as csv file. Once I put it on my desktop rather than a shared drive, I was able to use workbench and do a local file. I am going to try to do the Zip File option as well, because I think thats a really clever way to do this sort of task in the future! Thank you so much!

This discussion has been closed.