Domo Reply URL, has this been changed?

I’m trying to connect the SharePoint REST Connector to create a dataset from SharePoint files.  I’m having issues with the reply URL that Domo recommends implementing

 

https://oauth.domo.com/api/data/vl/oauth/providers/microsoft-sharepoint/exchange

 

It throws an error

 

AADSTS50011: The reply url specified in the request does not match the reply urls configured for the application: 'ef17ae94-c9e5-4ef9-a3d6-43ea23cbdd30'.

 

Any Ideas? I can authenticate correctly to Azure but it does not like the redirect URL

Comments

  • @user16909   When you deploy your Active Directory Web app to Azure you need to ensure you add this URL to the Azure Active Directory application (or have someone with the permissions to manage your application in AD to this for you).

     

    Go to the Azure portal: https://portal.azure.com sign in and click on the Azure Active Directory icon on the left. Then click on the ‘App registrations’ icon in the middle pane.  In the search box enter the application from the error message and choose ‘All apps’ from the dropdown:Screen Shot 2019-08-08 at 2.14.03 PM.png

     

    Click on your application, then the Settings icon, select the ‘Reply URLs’ from the list.  Paste in the name of the reply URL from the error message you had and ‘Save’:

    Screen Shot 2019-08-08 at 2.14.54 PM.png

    Now you should be able to connect without the error.