How can I prevent data being filtered if I graph by period

I have discovered that Domo is filtering my data if I choose to Graph by Year. This produces a problem because I need to reflect an accurante summary number. It only appears to happen when I graph by YEAR, Month, Quarter, etc. and I'm using a Date field in the X-axis. To convey this, I will use an example: I have 100 rows of data with the X-axis containing a date field called DateofEntry with data spanning over multiple years. My y-axis is count of records and the series is a status (open, closed). My summary number is set to have an overall count of records (i.e. 100 records). Leaving the Date Range as "all-time", if I set the Graph By to year (or anything other than none), my summary number goes to 95. I also appear to only have data being charted as of 1990. There are no other filters or sort at play and my source data file looks correct. 

 

If I create a beastmode to do a year(`DateofEntry`) and chart it by year, it works great, but I lose flexibility of the user charting it by another period. Any helps or insights appreciated.

 

Ryan Draughn

 

Comments

  • Ashleigh
    Ashleigh Florida 🟢

    @rdraughn  do you hvae multiple date columns in your data? What date range field is selected in the drop box for time range?

  • Hi @Ashleigh 

     

    Yes there are several different date columns in our data set. No matter which Date Field I elect to use in the X-axis, it behaves the same. If I graph by "None" I see all data, if I could by "Year", it filters data and I can't find a rhyme or reason of why certain data is filtered.

     

    And I'm using "All time" as the Date Range.

     

    Ryan

  • Ashleigh
    Ashleigh Florida 🟢

    Which date field are you using in the drop down menu, not the x axis. I provided a photo of what I mean. Also are you sorting the data by anything? If so try removing all of those and see if it fixes anything.