how to upload a csv of zip codes without casting them as numbers?

Hi folks, 

 

Just losing my mind here trying to upload a small csv file with zip codes. In excel, I have them cast as strings (since some zip codes start with 0). When I export to a csv, the csv has the zeros. When I import to DOMO, it takes the zeros away and zipcode 01760 becomes 1760. 

 

I've also tried putting quotes around the zip codes, but DOMO just takes those away as well. What's the secret here? I know there are probably hundreds of happy domo users uploading zip-code laden csv files every day. 

 

Thanks

Comments

  • If you haven't tried, try using the Domo Workbench utility to upload the csv. Within it their is an option to view and change the schema, so if it goes to Domo as a number (LONG or DECIMAL) you will be able to change that column to be STRING. Then when you upload it should reflect that.

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🟤

    If you are just uploading a list of zip codes, I would suggest you make use of the ZipToFips connector in the App Store. It has all of the zip codes and their associated fips code, which can be used to power the map cards. It has the zip codes as strings to account for the leading zeros. You can then join this dataset to your other datasets to power your cards.