Domo connector for Docebo

Hi,

 

I am having troubles trying to connect Domo with my Docebo instance. The knowledgebase article explaining the process seems to be missing of the essential part on how they want the API client to be configured in Docebo itself (see attached screenshot).

seemingly missing docseemingly missing doc

 

 

The error message I am facing is Failed to authenticate. Verify the credentials and try again. Domo is ready, but the credentials you entered are invalid. Verify your account credentials and try again.

error messageerror message

 

 

Has anyone had any success authenticating the Domo connector to Docebo?

Comments

  • @Luca 

     

    Thanks for alerting us to this, did you open a support ticket with Domo? https://support.domo.com

     

    I will have the Education team look in to this ASAP.

     

    CC @Trumpetbob42 @amyc 

     

    Regards,

     

    Dani aka "Mr.Dojo"

    Dojo Admin
    **Say "Thanks" by clicking the "heart" in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
    **You can update your Dojo Community name and avatar by clicking on your avatar then the "My Profile" button.
  • Thanks @DaniBoy ,

     

    I'll open a ticket and I will wait for the article update!

  • @Luca 

     

    Refresh your page and have a second look at the instructions as one of my team updated the relevant links and documentation.

     

    Let me know if this addresses the problem.

     

    Dani aka "Mr.Dojo"

    Dojo Admin
    **Say "Thanks" by clicking the "heart" in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
    **You can update your Dojo Community name and avatar by clicking on your avatar then the "My Profile" button.
  • @DaniBoy The article link points to the Docebo client configuration (which I had read already) but doesn't specify which particular settings Domo needs and how to fill them in (e.g. which grant type, which return URL, etc...).

     

    In any case, I've managed to make it work:

    • Given that Domo is asking for username/password AND for client id/secret I assumed that it needs the `Resource Owner Password Credentials` grant.
    • Domo doesn't specify a return URL to set in Docebo either and it seems it's not implementing one because it is now working with a random return URL.
    • The main point is that it seems that Domo is actually performing a pre-check on the provided URL to look for `docebosaas` and I was using a custom domain that has no such string in it (albeit being, of course, a valid Docebo hostname). After moving my configuration to another domain that has `docebosaas` in it I was able to make the connector authenticate. I would suggest to remove this logic or provide a more specific error message (if this check is actually being performed in the first place, I might be mistaken here).
  • Hi @Luca 

    I am facing the same issue, could you let me know how you moved your docebo url. My organiztion is also using a custom url which doesnt have docebosaas mentioned in it. 

     

    please advise

     

    thank you