Change Data Type from Importing

Hi, I am having problem when uploading Excel data which contains a column of invoice number. It has leading zeros however every time when I import the data, this column will become number type. 

I did searched here and found exactly the same problem. So I would like to know it's been years later can we select data type for Excel upload now?

https://dojo.domo.com/t5/Data-Sources-and-Connectors/Uploading-Excel-Data-Type-Issues/m-p/12423

 

I tried to change and make sure the data types are Text before upload, but it will change to number.

Thank you.

Comments

  • GrantSmith
    GrantSmith Indiana 🔴

    One possible work around is to add a prefix character (not a number) to your invoice number and then have Domo strip out the prefix in a data flow after you've imported your file.


  • @GrantSmith wrote:

    One possible work around is to add a prefix character (not a number) to your invoice number and then have Domo strip out the prefix in a data flow after you've imported your file.


    Yeah I can do that but my data has 20K+ lines and multiple files every month.

    Still hope DOMO can have the option to setup data types when importing. 

  • The struggle is real!  Very frustrating...