Table Card not showing all columns

Hello everyone,

I am building a simple (at least I thought) table card for my dashboard. The table only contains four columns, but when I save it, the card on the dashboard only shows three of them. I have played with editing the column width and the font size, but nothing helps. The card keeps showing only three columns. 

As you can see in the screenshot, there is enough space to wrap the second column and add a fourth one. 

Does someone know how to show that fourth column? 

 

Thanks in advance,

Koen 

Comments

  • Hi @Koen 

    it seems that one or more values for the customer column is very long.

    go to properties in edit mode and general, check the box allow text to wrap

  • Hi @Godiepi 

    Thanks for your answer.

    I did what you said but it doesn't solve the problem either. 

  • Three settings come to mind here.  

     

    • Allow text to wrap
    • Set Column Widths

    This is a percentage of the screen real estate.  For example, if you have 4 columns, but you set this to "20,50,30" then there won't be any room for the 4th column.  If you set it to "20,30,30" then the remaining 20% would be evenly split between the remaining columns in your table

    • The last option is "Hide Columns".  Obviously, if you have "4" entered here, you will not see the fourth column in your visualization.

    Can you confirm the settings for these three properties?  Or send a screenshot with these properties?1.png

     

  • @ST_-Superman-_ 

    I have done all of that, but it still doesn't work. 

    Is it possible that longer strings in the database - which are filtered out by a filter on this card - cause the column width of column two? 

  • Hi @Koen, are you viewing the card from a standard page or a dashboard? Standard pages typically only show 3 columns, but if you convert the page to a dashboard it should work.

  • Hi @MichelleH , I am using a dashboard.

  • I wonder if there are extra spaces in the Customer field that are causing it to take up all the width then? You could try a Beast Mode like this to remove any spaces:

     

    TRIM(`Customer`)
  • I'm also having this problem even after setting the Column widths and wrap text.  Looks like you can only show 3 columns max in a Table card then in a DOMO dashboard.  Isn't that great? More quirks to somehow remember....

  • I'm having the same problem except sometimes my table shows all of the columns and sometimes it switches to just showing three. I can't find any rhyme or reason to when it does it. I've tried doing all of the fixes listed in this discussion as well as shortening the text for each column using the LEFT function. Nothing seems to work except for random chance.

This discussion has been closed.