GA connector: update dimensions/metrics mid way

Hi everybody,

 

We are trying to streamline our GA connectors at the minute. This could entail adding some new dimensions to existing datasets or swapping dimensions.

 

I have done a test on a GA dataset to swap device category for date, and it did not work. The connector allowed me to do the change, but the new run did not change anything. The device category column became null, but the date column did not appear. This does not bode well for the streamlining we are trying to do.

 

Any idea guys? @jaeW_at_Onyx ?

 

Thank you very much for your help.

Best Answer

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤
    Accepted Answer

    @Manu_UKFD 

    I would take a very careful read of all the settings.

    To support customers with highly segmented GA datasets and retain multi-year history while minimizing throttling / Google enforced API rate limits, Domo implemented partitioning.

     

    In a nutshell Partitioning means "just update new data as it comes along."   It is possible that your settings are using Partitioning, and therefore, when you reran your connector with new settings it did not replace your full history and instead added the new column to the dataset (with NULL for historical data) and just checked for new data.

     

    For experiments sake, try setting up a new GA connector in with the settings you want to confirm you can get the desired results.

     

    If the experiment works, use the new connector in your ETLs OR revisit the existing connector to see if there's a way to force a reset of the data.  

     

    If you're confident there's a bug in the product, [email protected] can help!

Answers

  • Hi @jaeW ,

     

    Thank you for your reply!
    I'll check the settings you mentioned and will test things out.

     

    What you said around the partitioning could also explain why i cannot get historical data on brand new connectors. I can only get the day before, it cannot do historical data pulls... It shows the option for 30, 60 or 90 days but it never works.

     

    I'll try this out and will come back to you.

     

    Thanks again.