HTML link to external software

Hello,

I'm attempting to create a link on a table that will open up external software based on an invoice number but when I click the link that is generated, nothing happens.  The beastmod below works if I replace the "officelink" with "mailto" which opens up the mail app but it will not open officelink.  Is there something I'm missing or is this functionality not available in domo?  I'm not super familiar with HTML.

CONCAT('<div><a href="officelink://4d/invoices/:',`originvoiceid`,'">', `originvoiceid`,'</a></div>')


This should create "officelink://4d/invoices/:##########" which works fine if I just put it in as a url on my web browser.

Thanks!

Best Answer

  • GrantSmith
    GrantSmith Indiana 🔴
    Accepted Answer

    Hi @TylerMarshall 

     

    It appears that Domo only supports the http or https protocol when attempting to make dynamic links. Likely for security reasons but that's a guess. When it generates the page it completely removes any link information and you're left with a stand alone anchor tag with no href property if it's not one of those two protocols.  Is is possible there's an actual HTTP web page you could direct it to which would then redirect to the different protocol?

Answers

  • Ashleigh
    Ashleigh Florida 🟢

    @TylerMarshall  what type of card are you using this in?

  • Ashleigh
    Ashleigh Florida 🟢

    Here is an example of a link I created.

    CONCAT('<a href="', 'https://abcde.com/browse/', `Key`, '" target="_blank">', `Key`, '</a>')

  • I'm using an HTML Table.  I can create links to websites fine.  The issue is creating a link that will open the invoice number in a seperate program.  Even if I put in a link directly (not using CONCAT) using this for example:
    '<a href="officelink://4d/invoices/:22349529">22349529</a>'

    The link is created fine but when I click on it in domo, nothing happens.  If I replace "officelink" with "mailto" like I'm creating an email link, it creates an email to "//4d/invoices/:22349529" like it should which tells me my html code is fine.  This link works fine and similar links are used on other internal web based reporting (not Domo based).

  • Hey Grant!

    That makes a lot of sense.  I'll explore the possibilities of an HTML redirect but obviously that'll be far from ideal and require a bit more work.  Thanks for the info!