Dashboard Interaction with Drill Down

Is is possible to have a drill down interaction on a card which at the last level interacts with other cards? To give more detail we have an alert table on a dashboard that drills down from property level to the device level, showing problematic devices. Ideally, after drilling down from property level, one would select a device and all the cards below would show what's going on with that device. However, I cannot find a way to implement this, and currently the user has to manually enter the device info in another card for filtering. Even drilling and interacting at the same time would be fine but I cannot figure out a way to do that either.

Tagged:

Comments

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤

    Drilldown cards do not necessarily have to use the same dataset.  Between a Drill down from Lvl 1 to Lvl 2, you could theoretically switch from dataset A to dataset B.  Just be advised, as you drilldown, Domo will try to pass all the filters that have been applied in each drilldown to the next dataset, so you'll want to have consistent column names on filter columns.

     

    In other words, yes.

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤

    Alternatively, you can use pFilters to pass filters to a page via URL.  So theoretically, you get to your lowest level of drilling, then click a URL that takes you back to the dashboard with filters applied.
    https://knowledge.domo.com/Engage/Sharing_Content_Outside_of_Domo/Using_Pfilters_to_Apply_Filters_from_URL_Query_Parameters_to_Embedded_Stories

     

    Just... have a second thought though, it's usually considered poor UX to force me to click multiple times before I get to the data that I'm interested in seeing.  Is there any way to reorganize your cards so that it always just shows me the individual objects I'm interested in and discards the objects that are not of interest?

  • Hi Jae,

    I know of this feature however I didn't think that I could independently edit interaction settings. I will try that and accept this as an answer once I can confirm it works.

    Thank you.

    Demirhan

  • So yeah, unfortunately it doesn't work even though I am using different data sets at different levels now. The "Change Interaction" setting applies to both levels, no matter how I enter it. I have to try the other solution with Pfilters @jaeW_at_Onyx 

This discussion has been closed.