Single value card displays blank if specific date is selected in date range with existing data

Howdy,

I'm still pretty new to Domo so bear with me. I created a single value card to display a sum of completed tasks for a specific shift and office (2 filters) for a productivity dash. The issue I am having is that the card displays blank if a specific date (feb 15) is selected within a date range under my 2nd shift filter. The card will display the correct data if previous month, current quarter/year are selected as well as if I change the shift to another shift but not in a date range if feb 15 is within the range. I’ve checked all of my date data as well as the shift data and everything seems correct. Any clue on what I could be doing wrong here?

Answers

  • are you applying this date filter, under the filters tab? If so I would recommend remove that filter and then select the specific date from domo provided date selector.

  • Slapo
    Slapo ⚪️

    I am using the domo provided date selector to filter the dates. The filters I am using under the filters tab are text filters and not date filters.

  • GrantSmith
    GrantSmith Indiana 🔴

    Hi @Slapo

    Have you tried viewing your data as a table in analyzer and applying filters to see if your rows still show up? What happens when you lift some of your filters?

  • Slapo
    Slapo ⚪️

    Hi @GrantSmith

    When I change it over to a table it shows the correct data with both of the filters on. If I grab all of the data and perform the same calculation in excel as I did in the beast mode I created it gives me the correct number (with the filters on.)