Google Analytics Connector Column Type issue

ユーザー03386
edited April 4 in Connectors

Hello All,

I am having problems with the Google Analytics Connector.

The KeyCode management column of a custom dimension, which was recognized as a text type until last month, has suddenly changed to an Integer type.


Some IDs in the data still contain alphabetic characters, and I cannot resolve the ETL error.

It also displays "Could not parse as type Integer".


Reconnecting the connector again did not solve the problem.

I hope someone can advise me if they can find a solution.


Many Thanks,

Best Answer

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🟤
    Accepted Answer

    You can ask your CSM to enable Magic ETL 2.0. It has a lot of nice enhancements is definitely worth moving to. Looking at your issue, it's hard to say if it will fix this issue. This seems like a bug with the connector and you might need to reach out to [email protected] to have them look at it. You could also try creating a new connection and see if you still encounter the error.

Answers

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🟤

    Have you tried creating a basic ETL and using the Set Column Type tile to change the column back to text? Or if you are using Magic ETL 2.0 you can assign it right on the input dataset and then just link it to an output dataset.

  • I have tried a basic ETL and using the Set Column Type. But It doesn't work well.

    It also displays "Could not parse as type Integer."

    Below is the preview on ETL.

    And, I could not find Magic ETL 2.0...

    Thank you.

  • Understood.

    Then I will try to contact support.

    Until the issue is resolved, I will consider a manual response, such as importing the CSV output from the connector once again.


    Your answer is a good answer to my question.

    Thank you very much for your prompt and specific support.