YouTube Connectors Using YouTube Account Username and Password

Hi Domo Dojo Community,

I've been setting up some test YouTube Connectors in my Domo account. I'm using the Username/Password of the YouTube account to make the connection.

So far, no data has come in and its been several weeks.

Are there other barriers or settings which I can investigate in order to successfully connect?

Thanks

Answers

  • GrantSmith
    GrantSmith Indiana 🔴

    Hi @MrDomo

    Do you have an enterprise account and you're wanting to pull the specific channel's videos? YouTube makes it a bit difficult as you have to log in / authenticate as the brand page account and not the enterprise account.


    You account name would look something like *****-###@pages.plusgoogle.com. It'll be the same password as your main login account.

  • MrDomo
    MrDomo ⚪️

    Hi GrantSmith -

    I'm an Admin on all the accounts I have tried in Domo. So when Domo asks for the credentials, that is what I am supplying to them. Our company has several YouTube channels set up, but I have been made Admin on all of them.

    So I guess I'm not sure if Admin on these accounts makes me the Brand Account holder.

  • GrantSmith
    GrantSmith Indiana 🔴

    Each individual channel will have their own "username" which you need to use to login to YouTube to authenticate and pull your data, not the admin username.

  • MrDomo
    MrDomo ⚪️

    Thanks so much GrantSmith, I will try that today. 😀

  • MrDomo
    MrDomo ⚪️
    edited May 20

    Grant,

    After speaking with Domo support, it looks like there is an API issue between Domo and YouTube.

    I'm awaiting more information in the next day or so on how to proceed.

    It does seem my credentials are authorizing.

  • GrantSmith
    GrantSmith Indiana 🔴

    @MrDomo That's good to hear, please make sure to update this when you know more information for others who may have this same issue.

  • MrDomo
    MrDomo ⚪️

    I have done more research into this issue.

    Domo reported a 403 error on their back end.

    I met with my company Network Support to rule out internal errors.

    Domo requested I reach out to the YouTube Reporting Team.

    This issue is still open, although Domo has closed the ticket.

    My next step is to reach out to Domo support after I have seen what I can do on my YouTube account, which I am the owner of.