Google Analytics Advanced Connector - User count does not match with GA

I'm using the Google Analytics Advanced Connector and I can't seem to get the correct/exact count of Users when comparing to Google Analytics/Data Studio numbers.

I'm aware that Google Analytics aggregates the Users differently compared to the Sessions/Pageviews depending on my selected dimensions (i.e. in order for me to get the unique Users for each month, my only selected dimension/metric should be Month of Year and Users). Despite using the same dimension/metric from Google Analytics/Data Studio, the Users count still don't match (around +/- 50 difference). All other metrics like Sessions, Pageviews, Avg. Page Load Time, etc. match with GA except for Users so I can't figure out why.

Has anyone noticed this? Or is this expected?

Answers

  • Hi there,

    Our company has done a lot of work with the Analytics connector over the past 18 months and I've noticed that, as you said, it all depends on the selected dimensions that you're also bringing in. Out of curiosity, are you trying to mix Event data in with your dimensions? We had to create alternate datasets solely for Event data as the connector would not bring in this data accurately when trying to mix it with goals and goal conversions.

    Thanks!

  • Hi @Martellooooo, nope, I do the same by making separate datasets for events data. But thanks for pointing that out! Will take note of that.

    The dashboard I was asked to do has filters for Date, Source, and Country so in my dataset, so I initially selected all dimensions and metrics into one dataset. But that's when I noticed the difference in the count of Users, so I created datasets with no other dimensions except for Month of Year. Yet I'm still not getting the exact numbers as the ones in GA/Data Studio.

Sign In or Register to comment.

Hey, Stranger!

It looks like you're new here. Those who sign in get access to engage with even MORE fire content. To get involved, click one of these buttons!