Is it possible for a scheduled report to include a hyperlink?

We have a number of table cards that include hyperlinks but they do not come across as hyperlinks when you schedule the report to hit an inbox. Is there a way to enable the hyperlink in a scheduled report?

Best Answers

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon πŸ”΄
    Accepted Answer

    @MattGo I did just do a test using the HTML table card and if you have a column that has a hyperlink, it renders properly in the e-mail body itself and will take the user to the link. I did find that you need to make sure that your link is in one of the first few columns because it doesn't seem to show all of the columns in the e-mail if you have a lot of columns or some very wide columns.


  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon πŸ”΄
    Accepted Answer

    This is what the beast mode looks like:

    CONCAT('<a href=https://www.google.com>Google</a>')
    

    If your url is coming from the dataset, you would add additional concat arguments and use your fields.

Answers

  • @MattGo - I'm not aware of any way to do this. Most scheduled reports just link back to Domo if you click on the report (which would then have the hyperlink). However, I wanted to follow this conversation in case there was a feature that I'm not aware of :)

  • Ashleigh
    Ashleigh Florida 🟒

    @MattGo Scheduled reports are more like screenshots. You could try and include an excel in your report which people could then get the links from there (although you would have to create a report on a card and not a dashboard).

  • @MattGo I'm not sure if this helps your situation or not, but hyperlinks do work in scheduled reports if they are in the summary number.

  • MattGo
    MattGo 🟑
    edited January 14

    @MarkSnodgrass I assume your html column is a beast mode? Would you mind sharing that? The hyperlinks I have do not render as hyperlinks when I schedule a HTML table card.


    Thanks to everyone for the responses!

  • MattGo
    MattGo 🟑

    @MarkSnodgrass I copied and pasted your beast mode and got the same results. I see the hyperlink in the card in Domo but not in the email. I don't supposed there are any card settings you had to adjust or anything? Thanks!


  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon πŸ”΄

    Are you using the HTML table card? This is not the standard table card, but is found under tables and textboxes in the chart type dropdown list.

  • MattGo
    MattGo 🟑
    edited January 14

    @MarkSnodgrass Ahhh, I THOUGHT I was using an HTML card but clearly was not. Sorry about that and thanks again for all your help!

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon πŸ”΄

    @MattGo not a problem. Happy to help. If you can mark any answers as accepted that helped you, that will help others in the community.