Beastmode Formula - Not calculating / populating

DomoNewbie
DomoNewbie ⚪️
edited January 14 in Card Building

Hi - I created several beast mode formulas (TQ, LQ, QoQ %). When I add TQ and LQ to a pivot table chart, there are no issues populating the results.

When I subtract TQ from LQ, Domo seems to not want to perform that calculation. I can add TQ to TQ or LQ to LQ and that works.

Is it a Domo performance issue? Eventually I want to divide that difference to get a QoQ % Change. What seems to be the problem?

Thanks in advance!

Beast Mode QoQ formula:

--2_Quarters_ago

(CASE WHEN (QUARTER(CURDATE())=1) THEN (CASE WHEN ((year(`Quarter`)=(year(CURDATE()) - 1)) AND (QUARTER(`Quarter`)=3)) THEN `Value` END )

ELSE (CASE WHEN ((year(`Quarter`)=year(CURDATE())) AND (QUARTER(`Quarter`)=(QUARTER(CURDATE()) -1))) THEN `Value` END ) END) -

--LastQuarter

(CASE WHEN (QUARTER(CURDATE())=1) THEN (CASE WHEN ((year(`Quarter`)=(year(CURDATE()) - 1)) AND (QUARTER(`Quarter`)=4)) THEN `Value` END )

ELSE (CASE WHEN ((year(`Quarter`)=year(CURDATE())) AND (QUARTER(`Quarter`)=(QUARTER(CURDATE()) -1))) THEN `Value` END ) END)

Answers

  • GrantSmith
    GrantSmith Indiana 🥷

    Hi @DomoNewbie

    Do you have any NULL values in your Value field? Subtracting a null value would result in a NULL.



    **Was this post helpful? Click the heart icon**

    **Did this solve your problem? Accept it as a solution!**
  • Hi Grant - I was able to resolve this issue. I do believe there was a Null value in the dataset. I included a "Else 0" after the case statement and that resolved the problem.

    Thanks for following up!