Inconsistent positioning of Total Labels on Bar Chart

Hi All,

I have a bar chart that is graphed by month, with a series. I have selected "Show Total Label" under 'Data Label Settings'. I am not showing any other text. All the total data labels appear at the top except for 2 that appear at the base. They appear at the base because these 2 months contain a series with a negative number, however the total of the series is still a positive number. How do I make all the total data labels appear at the top, including the 2 with a negative series? I feel this could be a bug within Domo.

Appreciate any help.

Cheers

Answers

  • Hi @genaussie, after selecting "Show Total Label", there's an option to change the position from default to Outside, which will make those negative number labels appear at the top of the bar, or Outside Top, which will raise the labels above the x-axis.

    Unfortunately, the label positioning is pretty limited currently. Let me know if you are after something else.

  • genaussie
    genaussie ⚪️
    edited January 17

    Hi Amehdad,

    Thanks for your response. That setting is for the series labels but not for the total label. Also, I did try it and it didn't make a difference - the total label for the months with a negative series still appears at the bottom, strangely.

    Photo on left is original (note total labels in Feb and Jul 21 appearing at bottom). Photo on right is with your proposal - still appearing at bottom.

  • Hmm yeah that's odd. It's worth reaching out to Support [support.domo.com] to have them look at it as well.

  • amehdad
    amehdad 🔵
    edited January 24

    @genaussie

    How did you go with this mate?

  • Hi @amehdad

    Thanks for following up. I took your advice and reached out to Domo Support who are looking into it. They also indicated that the behaviour was strange, so probably just a bug. I will advise if I hear anything else of interest to this forum.

    Cheers