Google Sheets and Date Time

We are having some issues with a date time field that coming into Domo via the Goole Sheets connector.  We have another applicaiton that is writting data to the a google sheet that includes a time stamp.  


Here is an example 11/9/2015 10:56:54   After coming into domo this same field looks like this - 11/9/2015 2:56 AM 


And  11/10/2015 15:56:14  in domo becomes  11/10/2015 6:00 AM. 


We are using the google sheets connector.   Not sure what to do.


Thanks in advance.



  • Hi all,

    Can somebody help @jriley with their question?


  • Jriley,


    Thank you for contacting DomoSupport. Can you please provide a link to the datasource that you are using? Also what is your timezone? Do you know what timezone is being used in your Domo instance?

    Thank you,
    David W

  • Did you still need help with this?

    Thank you,
    David W

  • @jriley, can you answer the follow-up questions to better assist you?

  • We are having the same issue. The region setting in googlesheet is Eastern timezone but when domo imports it, it still thinks it's in UTC so it converts it to Eastern again which puts the timestamp in the wrong timezone and in some instances in the wrong day. For example, the auto-generated timestamp value is "2/24/2020 5:36:07", when it comes in through the googlesheet data connector, the value is converted to "Feb 24, 2020 12:36:06 AM" (this is now hawaiian time). Is there a way to fix this?

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🟤

    @user01804  in the Admin section, under Company Settings - Company Overview, there is a Time Zone setting. Make sure that is set to Eastern. Domo should be looking at this setting for imports.

  • @MarkSnodgrass  I just double chekced again and it is set to "America/Detroit". Since our DOMO and googlesheet are both under Eastern, there should have been no conversions but it's treating source data as UTC which has a 5 hours difference than eastern.

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🟤

    I didn't have a Google Sheets file to work with, but I did have a SharePoint Connector Excel file to test with and see that it is doing the same thing. Subtracting 5 hours. It could be worth a call to Domo Support to see if it is a bug with these connectors, or understand their reasoning for not adjusting the time to your time zone setting. 

    A workaround would be to create a beast mode to adjust the time by using the SUBTIME() function.