Changing a dataset on a card

How come when I change the dataset on a card it doens't change the dataset on the drill downs?  Is there anyway to fix this?

Best Answers

  • McSQL
    Accepted Answer

    This will take a little more in depth review. We will reach out offline to review in more detail.

  • DataSquirrel
    Accepted Answer

    Thanks for the quick answer! Here's what I think that I've seen from some simple experiments:

     

    * You can a warning if field names differ, even case-sensitively. I don't think that Domo normally treates names case-senstiively, but that brings up the warning dialog when you migrate.

     

    * Beast Modes seem to magically be recreated when you migrate. There's something in the docs about that, but I don't know what the nuances are.

     

    * If you've got a Beast Mode named DOW for a Day Of Week calculation in the old DataSet and migrate to a new DataSet with a real DOW column, there's no conflict. The old =DOW BeastMode i recreated and used.

    * Drill Downs sound like they break hard :( I've got code to pull all publically available informaiton from the Domo APIs and there's no trace of Drill Path details. The child chart don't appear, there's nothing about them. Same wth Beast Modes, they're invisible in the API.You seem to have to go in and review every single card by hand.

     

    * Not sure about PDP rules. They're associatedi with a DataSet, so, well, I guess I figure you just have to create the rules you need again from scratch.

     

    * User and group access...I guess that needs to be done again by hand.

     

    Hmmm. Seems like I should start a question about migrating card. What's going on is that we've been doing a Workbench push of Excel files and now want to do Postgres pulls. We don't want to change DataSet, just change how the DataSets are populated. But, unles I'm missing something, that's not how Domo works. It seems like once you create a DataSet, it's tied to the connector or import method you used originally...forever.

     

    It's midnight here...I might be a bit rambling. Any suggestion ore information much apprecaited! Thanks again for posting with details alredy.

Answers

  • Does this mean you have to manually change the dataset on the drill-downs? or that you cannot change at all?

  • Its possable to open each drill down in the editor and change it, but when you do it clears the drill card and deletes all your beast mode calculations.     Its like the the "Connect / Update Data" selection in the card dropdown menu only applies to the main card and not the drill downs.  Eventhough the datasets are exactly the same (except for the acctual data).

  • The reason for this is that our card builder has the ability to drill across different data sets. When changing the data set on the top level we don't always want the drill down to change as well. I like the idea of having a way to choose whether you want to change all levels on a card or just the current level.

     

    Please visit the Dojo Ideas Exchange http://dojo.domo.com/t5/Ideas-Exchange-suggest-and-vote/idb-p/Ideas. You can search existing ideas and then vote for it if it matches what you have in mind. If you cannot find it, please create a New Idea which can then be voted on by your fellow Dojo members.

  • Is there a way to keep it from clearing the drill card and beast mode calculations when I change the dataset?

  • @McSQL, please let us know if/when a solution is reached!

  • Hello everyone,

     

    This problem is 2-fold:

    • When the drill down view has the same dataset as the parent, when changing the parent it should also change the drill-down of the children, and also notify when there is a column compatibility problem with each of the children. @delsat, any plan for this?

    • I also noticed that when I am on a drill down view edit screen, when I change the dataset, it first shows me the small dialog that tells me if my columns are OK and I can see the view change fine in the greyed out background. But then when I press OK or the top-right cross, it then blanks out the view and remove all filters / field selection. Anyone experiencing this?

    Thanks!

  • It's been 2 years since this topic was first asked but is there still no slution to this? There's no easy way to update the data set in a further drill down other than recreating the drill downs?

     

    This seems unnecessary and tedious when you have the option on the top most level of the card.

  • I am also looking for a solution to this.  We have a dataset, let's call it DataSet_V1 that is updated sometimes at the HQ level.  I have about 20 cards based on this dataset.  When they move to DataSet_V2, I have to update each of my cards...as well as each of my drilldowns within each card. 

  • years later seems many of us are still having an issue with this...

    changing cards to a new dataset, and beasts / calculations not carrying over on cards, filters or sorting (despite having re-created all beast calcs in the new dataset).

    also will be a nightmare for all cards with drillpaths.

     

    no solution exists yet?

  • Thanks for your patience here I will bring this to engineering to see where we are with this.

    Regards,

     

  • I'm researching what's involved in migrating many cards to a series of new DataSets and ran across this thead. It's marked as solved, but not soultion is mentioned.

     

    Is this still an open issue?

     

    Thank you

  • Hi!  Changing datasets is pretty easy - however, beasts / calculations and filters on each card are reset, I haven't yet seen a solution implemented to carry them over.

This discussion has been closed.