My dates are all being transformed (subtracted by 5 hours) -- help!! URGENT

Friday morning ny team woke up to see all the dates in all our data sources being subtracted by 5 hours!! what gives?

they are already in the correct time zone and do not need adjusting! This is causing all sorts of data issues. How can I turn this new feature off?

Comments

  • Hi all,


    Can anybody help @punitfire with their situation?

    Thanks!

  • Hello @punitfire,

    Looking at your company settings, It appears your timezone settings are currently set to the: "America/New_York" Timezone. This time zone is -5 Hours from UTC. 

    When data comes into Domo, it is assumed that this data is formated as UTC time. Domo will then convert the data's dates acording to your timezone settings. In this case the data will have 5 hours subtracted from it to account for your timezone. 

    From t what you mentioned, it sounds like your company timezone setting was previously set to show UTC and was changed to: "America/New_York" when you started seeing this issue. 

    You as an Admin user have the ability to change your timezone settings back to UTC. To accomplish this you go to your drop down tool menu > Admin > Company Settings > Company Overview > Time Zone. 

    If you are only seeing the time change on a single dataset you can ensure the data is coming in as UTC or we can use a dataflow to add 5 hours back onto the date columns in this dataset. 

    Please Let me know if this resolves the issue you are seeing. If it does not we can connect through a phone call. 



  • @punitfire, did ilikenno's reply help you out?

  • As previous posters mentioned, Domo expects all datetime data to be in UTC. Workbench includes a "Shift Timezone" transform to assist with this. So if your data is in EST, you would add this transform to tell Workbench that is the data timezone. Then Wb will shift it (by adding or subtracting the appropriate hours based on timezone) so that the data in Domo is in UTC. Then when Domo displays or uses the data, it will convert it for your display based on your company settings.

     

    So it sounds like you probably need to add a shift timezone transform to your workbench job.

This discussion has been closed.