Date Format

I've got a SQL table where my dates are mm/dd/yyyy as shown in the before picture. before.PNG

 

When I create a dataset on this table domo reformats this date to yyyy-mm-dd as shown in the after picture.

after.PNG

 

 

My first thought is why is it converting the date to a different format?  But more importantly how do I change this so that the data set maintains the mm/dd/yyyy format.

 

Best Answer

  • Godzilla
    Godzilla 🟢
    Accepted Answer

    i completely agree with you on having the ability to set the default date format. it's something I have to modify in almost every card. 

     

    On a card by card basis, you can also use beast mode to convert it to the format you want. You can do something like this: 

     

    DATE_FORMAT(`MyDateColumn`, '%m/%d/%Y')

     

    this article covers date formatting in Beast mode http://wiki.domo.com/confluence/pages/viewpage.action?pageId=37460365 

Answers

  • you can change the format back in the chart properties. Go to Category Scale (X) under CHart properties and hover over the Date Output Format field. It will give you examples of how to format. if you want to change it back ot the format you had in your first screenshot, i think typing in the following in the Date Output Format box will do the trick:

     

    M/dd/yyyy

     

     

  • Thanks for the response.

    That works for a chart/graph but I'm actually using tables to essentially look at data in a tabular format.

    In table settings there seem to be no options to change the format.  I would like the default date format to always be mm/dd/yyyy otherwise I need to format the data in ever card I will make from here on out.  It would be ideal to do it in one place and never have to account for it going forward ?

    table view.PNG

  • Wow that is crazy you have to make calculated fields for every date you'd like to do this too.  Especially if I look at my dataset, the date is formatting properly so Domo had to make an effort to convert my format rather than just use it.

     

    Your workaround works well though, thank you!

  • is it possible in date format to change it into a integer format eg: February 2016 is 1/2016 is that only possible in beast mode?
  • Crazy is an understatment. Simple problem with a complex solution. Fix it Domo!