"Invalid Schema, Check Your Dataset Query" error


I only saw a few questions related to this on Dojo and figure I might ask. My dataflow has always ran fine (created in May 2021) but yesterday there was an error that showed up. I'm not able to preview the dataset, and I tried to refresh the ETL multiple times and reset the schema (deleted all columns from the python script schema and re-added again) and I'm still getting an error.

This error is really vague and I am not sure how to troubleshoot.

Can someone please help? Thanks!



  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤

    refresh your browser.

    if you run an ETL that laters the schema of a dataset, sometimes the browser doesn't know that ta column no longer exists until you refresh the page .

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🟤

    I would check to see if one of the data type of one of your fields is different. Such as changing from integer to text because some of your data is different. This would cause the error. Also, if you are using Domo Workbench to import the data, you need to refresh the schema in there. Click on your job, then click on the preview icon and then click on the schema tab to verify the fields and types are correct. Then click execute.

    Hope this helps.

  • Hi @jaeW_at_Onyx and @MarkSnodgrass - thank you both for the suggestions and your help. So I ended up changing the data type from floating decimal to fixed decimal for all numeric columns and it resolved the issue. I'm able to see the dataset now and the data loads fine in the dashboard. Still not sure why floating vs. fixed decimal would cause an issue... but I'm guessing this is resolved!