SDK notes for unix troubleshooting

Hey all.



After reading the Domo-SDK-Guide.pdf file, I wanted to make a little note that it may not work for everybody exactly as written. Basically, 


Step 2 says:

$ domo login


Ok, I tried that.

[[email protected] ~]$ domo init

/usr/bin/env: node --harmony: No such file or directory


I banged my head checking to see if all the binaries and versions were there, everything was fine.



If you look at the command that ryuu installs in /usr/local/bin/domo 

[[email protected] ~]$ head /usr/local/bin/domo

#!/usr/bin/env node --harmony

var os = require('os'), path = require('path');

process.env.BABEL_CACHE_PATH = path.join(os.tmpdir(), '/ryuu.json');

// enable awesomeness

require("babel/register")({  stage: 0,



It's just a wrapper application you can trigger as a node paramter. Presto, all works, and this is what all the developers are doing.

Like so -- > node --harmony /usr/local/bin/domo init (or login, or dev, or whatever) 




Maybe /usr/local/bin/domo should be an executible shell script roughly like..



node --harmony  /usr/local/lib/node_modules/ryuu/bin/runner  $0



3 more quick notes

1. In the unix world, I had a huge issue with permissions and ended up installing everything as root, even though the documentation said not to. Worked fine, probably better because the developers don't really know how to work with node so I installed it on the box for everybody, not just for one user.

2. If you know the trick above about firing from node, it's probaly no more than 20 minutes to spin up a free tier instance at amazon. Makes sense that we build an ansible playbook and have instructions in the guide for running it. Developers usually don't knwo too much about unix.

3. Node itself has some serious issues on Windows Server 2013. Don't waste you time. Switch to linux (we used AMI) or stick to Windows 7. 



Thanks guys! Great docs here, made it really easy for us.






NBC Analytics Technology
1 votes

· Last Updated


  • Thanks for submitting this @tonythor.  I am the product manager for the Domo Apps teams that cover the tools (Dev Studio - SDK and Design Studio).  These are good suggestions.  I'm going to review with the team and make sure our documentation is updated.  Appreciate you taking the time to respond.

  • Thanks @product_John Jeff G from our team tested this on his mac today, he got the same thing. He had to run node --harmony /usr/local/bin/domo too, but that does work for him.



    NBC Analytics Technology
This discussion has been closed.