Feature Request: Don't use env, and clean up graceful-fs

I'm triyng to get ryuu up and running on cloud9.io, and I've run into a few issues.


The first one is that c9.io installs nvm by default, and the domo shell script doesn't like it:


woganmay:~ $ domo
/usr/bin/env: node --harmony: No such file or directory

I do have node, installed and managed via nvm:


woganmay:~ $ which node

That's resolved through a symlink at /usr/bin/node - and in most cases a symlink like that should make node work correctly. Not for ryuu though, which is why I've had to change it from this:


#!/usr/bin/env node --harmony


To this:


#!/usr/bin/node --harmony

It now works more or less as expected.


woganmay:~ $ domo -v
(node:1635) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

And there's the second issue - the dependency for graceful-fs is outdated. I also get errors related to that when installing ryuu. Would be nice if they could be cleaned up

Technical Consultant @ Acceleration


  • I still get this error when installing the latest version of ryuu:


    npm WARN deprecated [email protected]: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to [email protected]^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
    Technical Consultant @ Acceleration
  • Hello @woganmay, thanks for taking the time to post your question here.  We are not currently supporting Cloud9 with our tool.  This is a great idea though and I will make sure to get it on our backlog.


    Our developer portal outlines the installation guidelines we currently support:  https://developer.domo.com/docs/dev-studio/dev-studio-get-started


    Would it be ok if I reach out sometime soon for some more information on how you are using Cloud9 as an online development environment?



  • Hi @product_John - I don't think it's as much about supporting cloud9 specifically, but more nvm generally, which is used pretty widely in the node community: https://github.com/creationix/nvm .


    I'll be trying to set up Dev Studio on a pure Linux machine later today, and will test if nvm is really the cause.


    And yes! Reach out whenever. You should be able to PM me directly here via Dojo.

    Technical Consultant @ Acceleration
  • I just tried setting it up on a brand new Linux Mint installation. I used the jessie/sid repository versions of Node, and ran into the same problem with the domo app - taking out "env" fixed it.


    I'm going to rebuild the machine and try installing Node directly from their repositories.

    Technical Consultant @ Acceleration
  • @woganmay - let me go talk to our engineering group today.  I mentioned this late last evening and their first reaction was that it should be fine.  I might reach out for some more information from you if that is ok.  

This discussion has been closed.