Unable to install App Dev Studio on Linux Mint 17.3

I'm running the latest Linux Mint version (17.3, 64-bit), which is a Debian-based OS. I've tried installing all the dependencies and the Dev Studio, but it's not working. Here's the exact commands I've run since completing a fresh reinstall of the OS:


sudo apt-get update
sudo apt-get install curl

I needed curl to follow the official installation instructions.


curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
sudo apt-get install -y nodejs

These ran without issues, added node 6.x to my apt repo, and install nodejs proper:


which node /usr/bin/node
node -v v6.1.0
npm -v 3.8.6

So that's a clean, default install of the latest version. I then tried installing ryuu:


npm install -g ryuu

It downloaded all the dependencies but failed at the end - write access denied to /usr/lib/node_modules. It suggested re-running the installer as root, which I did. I know that there are other workarounds, but they achieve the same result:


sudo npm install -g ryuu

That got past the symlink stage, but then failed:


make: g++ Command not found

Due to that failure, a node-gyp module doesn't build, and so the postinstall script fails (error: haystack.get() is not a function).


I imagine it also needs build-essential in order to install, which is not specified in the Dev Studio install instructions, nor checked for up until this point. So:


sudo apt-get install build-essential

That finishes and I run the install command again:


sudo npm install -g ryuu

The install completes, throwing some warnings about fsevents, which is not compatible with my operating system or architecture.


And still:


[email protected] ~ $ domo
/usr/bin/env: node --harmony: No such file or directory

So I fixed my npm permissions using option 2 from this guide. I then re-ran the installer as my own user:


npm install -g ryuu

The install finished with no errors, and the domo executable installed into the correct user-specific location:


[email protected] ~ $ which domo




[email protected] ~ $ domo
/usr/bin/env: node --harmony: No such file or directory



Any suggestions?

Technical Consultant @ Acceleration


  • Hi all,


    Can anybody help @woganmay with their situation?


  • Hi @woganmay, I will pass this along to our engineering team and update you today on steps to take.  I apologize for the inconvenience.  We will help you get installed.

  • @woganmay, recommendation from engineering is to try to install this using Node 5 as a workaround.  We are working to get Node 6 support in as soon as possible.

  • I'll give that a go in my cloud dev environment, thanks!

    Technical Consultant @ Acceleration
  • @woganmay, please keep us updated ?

This discussion has been closed.