Unable to import DataSet Jobs successfully

I am unable to import DataSet files and then succesfully uploading to our domo server.


As a way to duplicate DataSet Jobs, in order to save time redoing schemas and transfroms I tested exporting a working DataSet job and then importing it back, changing the DataSet name when asked by workbench.

when I then try to run the Job it fails and says: Response status code does not indicate success: 500 (Server Error).


I cna then find an instance of said job in our server but every time the Job rusn again it creates a extra instance of the DataSet instead of replaing it. Making any reruns of the Job useless.


I tried importing a DataSet that I know worked before exporting/exporting, deleting the old DataSet Job and running the Job without modifying the Job or Name (any many combinations of those) but i always get the same outcome.


I am worried also that when I change the computer used to run workbench I will have the same issue and have to redo all DataSet Jobs again.

Best Answer

  • rado98
    rado98 🟠
    Answer ✓

    The issue was resolved by reinstalling the workbench. Now I can export and import the same job as it should


  • @rado98 I think your suggestion here is to create an option to duplicate DataSet jobs in Workbench so that you don't have to go through the workaround you described above, is that fair?


    For some context, how many WB jobs do you have to create? Are they all roughly the same (same type, DNS, source)?


    I'll look into the error you are having in the short term, but long term we will look at adding a duplicate job feature so you are not having to export and import jobs in an attempt to duplicate.

    Alex Peay
    Product Manager
  • A duplicate function would be ideal.


    I have probably 10 or so WB job that would benefit from a duplication function.


    I am setting up DataSets from Excel spreadsheets so I find myself changing to the same schema and transforms over and over again just because similar data is set up across different tabs. Although I have found some work around for some things a batch data type changing funtion would also be apreciated.


    Is the issue simply that I am importing data generated on the same PC? Should I expect similar issues when importing to different PCs?


    Thanks for the quick follow up.


  • Are your schemas the same or are you having to pull them into a common schema for the transforms? Would there be a reasonable expectation on my part that the transforms would have the same columns to use?


    I would suspect your issue is that it is the same machine with the same Agent ID.

    Alex Peay
    Product Manager
  • @rado98, tagging you in case you haven't seen alexpeay's latest response. 

  • A duplicate function would be great.  Or, the ability to create a job via command line.  We currently have 75 jobs and I have been asked to bring in two other SQL databases that have over 100 tables each.

  • @COWsupport have you looked at the Domo Public APIs? This may be a better option for your importing data needs:



    Alex Peay
    Product Manager
  • @COWsupport


    You can also do some work on the CLI, follow the link here to the Domo help center to learn about running jobs from the command line:



    Alex Peay
    Product Manager
  • It would be great if you could create a dataset via command line.  We have our partner looking into the API for us.  Thanks.

This discussion has been closed.