Data Transformation || R Connectivity || Automation

We have a business scenario wherein we need to do data transformations for a data with source from cloud. We need the data to be exported to R or similar tool and import back to DOMO after transformations. We need to automate this process.


Please provide us the steps/process to do this.


Thanks in advance...!!!

Best Answer

  • kamuela



    Answer ✓

    @Wilko There are a couple package dependencies that cause this issue.  You need to make sure that you have httr version 1.0.0 or lower and readr 0.2.0 or lower installed in your instance of R.

    I am no longer with Domo. Please @mention @Millhouse for connector specific questions.


  • Hi all,


    Can anybody help @Neeraj out?


  • DomoCodyW
    DomoCodyW American Fork, Utah



    Hi @Neeraj,

    You could certainly use Domo’s connectors to download data from various 3rd party cloud sources. Within Domo, you could complete any pertinent transforms on the data and output it to a dataset. You can then export that data out of Domo using Domo’s API, which will provide a CSV dump of the dataset. Details on integrating with Domo’s API can be found in the Domo Developer Portal:

    ** I work for Domo

  • @Neeraj We also have a plugin for R that simplifies the moving of data between Domo and R.  After installing the plugin in R, you can create a new Domo DataSet directly from R or you can retrieve an existing DataSet from Domo, run your tranformations in R and then push the changes back into Domo.  It is currently available as a beta release.  Feel free to message me directly if you'd like access to it.






    I am no longer with Domo. Please @mention @Millhouse for connector specific questions.
  • Hi @kamuela,

     I've been given the DomoR plugin, and am currently exploring it.


     One problem I have encountered is the fetch command (DomoR::fetch). When I run it I get the following error:


    Error in readr::read_csv(x, locale = readr::locale(encoding = encoding),  :

      unused arguments (check.names = FALSE, na.strings = "\\N", colClasses = c(NA, NA, NA, NA))


    The dataset I'm calling exists and has data in it.


    I thought initially I had to explicitly name the columns ie c() but that made no difference.


    Is this something to do with library versions in devtools package? Have you guys come across this problem before?





  • Hi @kamuela

    Many thanks your answer was right on the mark. Problem Solved.





  • Hi,


    How do we get a hold of the R package?



  • Hey @vblain if you want to send me a direct message with your Domo login URL and an email address, so I can see which customer account you are part of, I can send you the details.





    I am no longer with Domo. Please @mention @Millhouse for connector specific questions.