Google page speed API verification always fails

I've been trying to add the Google PageSpeed Insights connector, but every time I add my API key for PageSpeed Insights it says it is not valid. 


I've copied and pasted the API key EXACTLY as it appears in my Google Console, but every time I get the message:

"Failed to authenticate. Verify the credentials and try again. Domo is ready, but the credentials you entered are invalid. Verify your account credentials and try again."


My API key is currently locked to http requests from "**", but I've also tried the API key without locking it as well (aka unrestricted).  Still no luck.  Maybe requests are not coming from the domain?


I've also noticed in my Google Console account that the majority of the calls hitting the PageSpeed API are returning either a 403 or 400.  What's weird is that there are a few 200 success responses. (see image)


Anyone else running into this problem?

Best Answer

  • user03643
    user03643 ⚪️
    Answer ✓

    I figured it out.  


    There is a delay on Google's side when you change the permissions for the PageSpeedInsights API in Google's developer console.


    I, apparently, was not waiting long enough for the change to propagate through Google's system prior to creating a data connector.


    After waiting about 10 mins, the data connector connected successfully.