SFTP connector - not finding all files

I used the CSV Advanced connector to set up a SFTP connection to pick up a daily file and append to the Domo data source.  However, on the 2nd day the feed was supposed to run, it failed with a 'file not found' error.  I tried to review the settings but when I choose the option to select a file from the sftp location, the file I need is not listed there - and have confirmed it is there in the sftp folder.  In fact, there are 82 csv files in the sftp but Domo is only displaying 13 files.  It doesn't seem to be showing only the most recent files, some of the 13 files it's showing are several days older than the one I'm looking for.

I have also tried creating a new sftp connection with the same results.


Has anyone encountered this and/or have any thoughts?


Best Answer

  • user02369
    user02369 ⚪️
    Answer ✓

    I didn't get an actual solution to this, but checked back a day or two later and was able to see the files I needed.


  • Make sure your file type still a CSV.

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • Yes, as I mentioned all 82 files in the folder are csv but Domo is only displaying 13.  Thanks

  • Hello,


    I am trying to setup the SFTP connection, so one of the department can drop the file tothe local DOMO server. But looks like it asks for the password. Which I am not sure how that worksd- is it the .Pem key/ Dataset id. 

    It would be great if you could tell me how did you setup the SFTP Connection.



  • Sorry, i just copied what someone else did on that connection, so i don't know much about the details.  I suggest starting a new thread for your own inquiry instead of as a comment here so others will see your question and help.