MS Sql Server error Domo is ready but Sql Server returned: Connection reset


I am using Microsoft SQL Server. We had our user configured and working in multiples datasets. But 4 days ago we started seeing a problem when updating the data from our server the error description is "Domo is ready but SQL Server returned: Connection reset". Complete error description when I tried to create a new account with same credentials: "Failed to authenticate. Verify the credentials and try again. Domo is ready but Sql Server returned: Connection reset"

I checked the following thing in our end: 

                        - The user could access from SQL Management Studio with the same credentials and has permissions to execute the same queries included in DOMO.

                       - The port is opened in SQL server to execute queries from DOMO system. 

                      - The user has the same permission before the problem started.

                      - The list of IP's white list IP's server is configured in our server correctly. 


 I appreciate any help here. 



Best Answer

  • Adrian_Car
    Answer ✓

    Hi @mensajero 

    We were 1 month out without reports. It was an issue in DOMO. We opened a case with them but finally, customer service said: "It was an issue in our end now it is fixed". And it is true now in our case it is fixed, but looks not good service because we checked the whitelist multiple times because they assumed the issue was in our end in the configuration.


    To be honest, I was confused about it and uncomfortable with the general service, and after closed the case, they never mentioned the root cause of the problem only closed the case.


    I will close the case with the solution in case it will be helpful for someone else. 


    I appreciate the help here.




    It's possible that you are trying to pull too much data at one time, try limiting the import.

  • Thanks for answer @BrendanH . I tried that option but it didn't work. I tried also to create a new connection with the same credentials and host but testing the connection failed with the same error. I tested the credentials with management studio from my computer same port, host and credentials it worked as expected. 

  • Same issue over here, started 2 -3 days ago. I can connect with same credentials via several other MS SQL clients....